Voucher Issuance Failure
Incident Report for Pay & Connect
Postmortem

This morning we experienced an interruption to the voucher issuance service due to a breaking change on one of our third party integrations that was deployed late last night. The change hampered our ability to successfully process transactions. Our service provider has since to have fixed the issue and the system was back to normal at 10:44 am, in time for the lunch rush. The voucher issuance cutoff had to be extended to 1pm to allow students the opportunity to issue themselves vouchers for the day.

We would like to sincerely apologise for the inconvenience caused as a result of this incident. We have been assured that the issue has been resolved, but we are following up for more information regarding the details of the recent deployment. We will continue to monitor the situatuon closely, and have requested that mitigating measures are taken in collaboration with us in order to prevent such incidents going forward.

Thank you for your patience and understanding.

Posted Nov 01, 2019 - 18:33 CAT

Resolved
This incident has been resolved.
Posted Nov 01, 2019 - 13:22 CAT
Monitoring
A fix has been implemented and we're monitoring the results.
Posted Nov 01, 2019 - 11:43 CAT
Update
We are continuing to work on the issue and will provide a further update as soon as we can.

This issue only affects voucher issuance and meal entry scanning remains unaffected.
Posted Nov 01, 2019 - 10:27 CAT
Update
We are continuing to work on a fix for this issue and will let you know when the issue has been resolved.
Posted Nov 01, 2019 - 08:33 CAT
Identified
A breaking change was made by our partner which has resulted in voucher issuances failing today
Posted Nov 01, 2019 - 08:30 CAT
This incident affected: Pay & Connect Service.