Invalid Recipient Error
Incident Report for Pay & Connect
Postmortem

We apologize for any inconvenience caused as a result of this issue.

When making a payment to a merchant, students have the option to either scan a one time QR code displayed directly within the merchants P&C App, or to scan a printed permanent QR code displayed by the merchant at the cash register.

While the format of the contents of the one time QR codes is standardized, the format of the contents of the printed permanent QR codes is not standardized.

Upon further investigation it was confirmed that the issue was isolated to payments using the printed permanent QR codes. It was discovered that there was a check on the QR code contents when completing a payment to ensure that it was standardized. This check should have been removed, but was included by error. After removing the check, the issue was resolved.

Posted Feb 10, 2023 - 18:06 CAT

Resolved
It was reported by a number of merchants that some students were having issues scanning merchants' QR codes when making a payment.
Posted Feb 09, 2023 - 15:30 CAT